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Pro Media Tools

User Manual

Pro Media Tools is a suite of utilities designed to simplify media management and streamline 
workflows for Final Cut Studio, Final Cut Pro X, Avid Media Composer / Symphony and Adobe 
Premiere Pro for Mac. 
The suite contains tools for offloading camera memory cards, editing QuickTime movie 
metadata, watching render files, editing markers, and much more. The applications are 
capable of outputting a variety of file formats to suit different editing systems and workflows.

Pro Media Tools includes:

Auto Transfer - Automatically offloads from camera memory cards to your computer. It can 
copy to multiple destinations at once, verify the copied files to ensure integrity and even 
embed relevant metadata in a spreadsheet.
Batch Renamer - Renames multiple files at once with options including find and replace, 
frame renumbering, frame padding and more.

Edit Detector - Scans video files to locate where edits and scene changes occur. Can output 
QuickTime movies, marker lists, Final Cut Pro XML files and EDLs.

Post Haste - Create folder structures for each project from customizable templates.

Project Overview - Provides a complete overview of your Final Cut Pro project, showing you 
all media, effects and markers. Data can be printed and modified en-masse. Can be used for 



Pro Media Tools User Manual    2

mass-editing markers with offsetting, custom fields, label presets and the ability to import Avid 
locators into an FCP project.
(Not supported by Avid Media Composer or Final Cut Pro X)

QT Edit - Edits QuickTime movies. You can add and remove media, edit timecode 
information, modify chapters, change metadata and more. All changes are displayed in a real-
time preview window. 

Quick Bins - Automatically sorts media into bins according to various criteria. Very useful for 
quickly sorting an untidy mass of dailies.
(Not supported by Avid Media Composer or Final Cut Pro X)

Render Watcher - Watches a set of directories, render files or Compressor batches and 
notifies you via a sound and Growl notification when renders are complete. Can be set to 
sleep, log out or shut down the computer when all renders are finished. 

Timeline Tricks - Performs common cleanup tasks on sequences including replacing gaps 
with slugs, collapsing tracks, removing unused tracks and stripping filters.
(Not supported by Avid Media Composer)

Video Check - Scans a video file for illegal luminance values, flash frames and audio peaks 
and shows the exact frame where errors are occurring. Can output results to FCP marker 
lists, Avid locators, CSV and text.  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Quick Start
After installation, a launcher application can be found at /Applications/Digital Rebellion App 
Launcher. This launcher is provided to make it easier and more convenient to launch the 
applications in the suite.
The applications themselves are installed by default to /Applications/Digital Rebellion/Pro 
Media Tools.
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Digital Rebellion App Launcher

The first application you will see after installing Pro Media Tools is the 
launcher, located inside your Applications folder. This can be a useful way 
of launching the applications, but you can still launch them with another 
launcher such as Spotlight or manually through the Finder if you prefer.

All Digital Rebellion applications inside your Applications folder will appear in the list. To 
launch an application, double-click it or press Enter.  

Registration 

To register Pro Media Tools, first visit http://www.digitalrebellion.com/promedia and click the 
Buy Now button to purchase the suite. Our system will automatically email a license to the 
email address used to make the purchase.
To display the registration dialog, either go to Help > Register > Pro Media Tools in the 
launcher or Help > Enter Registration Key in one of the applications. 

http://www.digitalrebellion.com/promedia
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In the dialog that appears, enter the registration information exactly as written in the 
registration email, with no variations. For example, if it says “Alan” on the license, you must 
enter “Alan” and not “Al” or any other variation.
The company name field is optional and is set when making the purchase. If this field is blank 
on your license, you must leave it blank when registering.
The product key field is best copied and pasted directly from the email. It consists of numbers 
and capital letters only.
Click Register to complete registration. If no error is reported and the window closes 
automatically, it means your registration information was accepted. If an error is reported, 
double-check that the information entered exactly matches the contents of the registration 
email. If you have purchased multiple Digital Rebellion products, check you are entering the 
registration information for Pro Media Tools and not another product. 



Pro Media Tools User Manual    6

Auto Transfer

Auto Transfer is a tool for transferring media from camera memory cards 
to your hard disk. It can copy to multiple destinations, verify the copied 
files against the originals to ensure their integrity and perform various 
actions once the file transfer is complete, including showing the completed 
files in the Finder and importing QuickTime movies into Final Cut Pro 
automatically.

There are two modes of operation – manual and automatic. To switch between the two 
modes, toggle the Auto Mode button on and off. 
In manual mode you must select a drive and click the Transfer button in order to initiate a 
transfer. In automatic mode, transfers take place whenever you insert a new drive. Auto 
Transfer will launch itself automatically to transfer the drive if it is not already running. (To stop 
Auto Transfer from automatically launching for a particular drive, select the drive in the list and 
click Ignore Volume.)
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Quick Start
1. Connect a drive or camera to your computer.
2. Launch Auto Transfer.
3. Type a name for the project in the Project field.
4. Optionally include a path to a Final Cut Pro project. This will allow Auto Transfer to 

import the transferred files into the project automatically. This function only takes place 
if the files are in QuickTime Movie (.mov) format on the card already, such as if they 
were shot with a Canon EOS 5D.

5. Click the Transfer button to begin automatically transferring the media.

6. When complete, click the Eject button.  

Destinations
Auto Transfer can copy media to multiple destinations at once. Use the Destinations tab to 
manage destinations.



Pro Media Tools User Manual    8

You can also set destinations on a per-volume basis by selecting the relevant destination from 
the dropdown menu under the Destinations column in the Transfer tab. This requires the 
destination to be set up in the Destinations tab first.
Although Auto Transfer can copy to multiple destinations at once, for performance reasons it 
is not recommended to copy to multiple destinations on the same drive simultaneously.

Metadata
The Metadata tab allows you to setup metadata fields that can be used to tag each volume 
with additional useful information. This information can be used to create the destination path 
(for instance by creating folders for each day or reel) or it can be added to a spreadsheet.

There are two ways to generate metadata. You can either make it user-visible and have the 
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user enter relevant information, or alternatively hide it from the user and fill it with computer-
generated data (such as the current date or an incrementing ID number) or a fixed value.
The Title field sets the column header in the Transfer window (if it is user-visible) and in the 
spreadsheet.
The Type field allows you to choose from the following options:

• Text - Plain text

• Number - A numeric value

• Number (auto-increment) - A numeric value that will automatically increase with 
every new drive that is mounted. This is an automatically-generated value.

• Timestamp - The current time. This is an automatically-generated value.

• Date - The current date. This is an automatically-generated value.

• Username - The name of the current user. This is an automatically-generated value.

The Default Value field allows you to specify the default value to appear within the field when 
a drive is mounted. You cannot set a default value for some of the automatically-generated 
data types.
The Visible field allows you to specify if the field is visible to the user within the Transfer 
window. Switch this off if you want to use an automatically-generated or default value that you  
do not want the user modifying.
The Use in Path field specifies if the value of the field should be used as part of the 
destination path. Use this to automatically organize copied files on disk based on information 
such as the current date, reel, camera, etc. You can see a preview of the proposed 
destination path in the bottom right corner of the window.
Use in Spreadsheet specifies that the information will be added to a spreadsheet (CSV file) 
within the project directory, providing that this option is switched on in the Actions tab (see 
below). 
Note: if a conflict occurs within the metadata information that leads the destination path to 
point to a folder that already exists, Auto Transfer will append additional data to the filename 
to ensure it is always unique. This means that you do not need to worry about data being 
overwritten, no matter what the user enters in the metadata field.
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Actions

The following actions can be performed after transferring a volume:
• Growl notification – Displays a message if you have Growl installed
• Play sound – Plays a sound
• Eject drive – Automatically ejects the volume
• Show files in Finder – Launches a Finder window showing the files that were 

transferred
• Open .mov files in QuickTime Player – If the media files are in QuickTime Movie 

(.mov) format on the drive, they can be opened up in QuickTime Player for playback
• Add .mov files to Final Cut Pro project -  If the media files are in QuickTime Movie 

(.mov) format on the drive and a project path has been specified in the Transfer tab, 

http://www.growl.info/
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Auto Transfer can automatically import the files into Final Cut Pro.
• Archive to Disk Image / Zip File – Creates an additional copy of the volume as a ZIP 

or DMG file after the transfer has completed. 
• Add metadata to spreadsheet inside project directory - Creates a CSV file inside 

the project directory containing metadata where “Use in Spreadsheet” was ticked in the 
Metadata tab. Transferring additional volumes will append data to the end of the file.

Frequently Asked Questions
Q: Why is my drive appearing as Unknown? 
A: This is because the particular format of the drive is not supported by Auto Transfer. This 
drive will not be transferred automatically but you can still initiate a transfer manually with the 
Transfer button. Please contact Digital Rebellion's support department to request any formats 
Auto Transfer doesn't already support.
Q: Why is Auto Transfer using up so much memory? 
A: This is due to a bug in OS X 10.6.0-10.6.6. To fix it, please update to OS X 10.6.7 or 
higher. Note that this does not affect users running OS X 10.5 Leopard.
Q: My transfers seem to be failing frequently – why is this? 
A: This is most often caused by an overheating card reader. Leave the card reader to cool 
down for ten minutes and try again. If the problem persists, it could be a faulty card or reader.
Q: Why does verification take so long? 
A: In order to verify, Auto Transfer needs to check the data on the card and the data copied to 
your drive. This means it has to check twice as much data (or even more if you have multiple 
destinations set) which can sometimes mean that verification takes longer than the transfer 
itself. To speed up verification, only use one destination and ensure it is on a fast hard disk or 
RAID.
Alternatively, you may prefer to deselect checksum verification in preferences and only 
perform a file size check. This is fast and will find obvious problems but is not as thorough as 
a checksum verification.
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Batch Renamer

Batch Renamer is a tool for renaming large numbers of files at once. 
Unlike other renaming tools it is designed specifically for post production 
workflows and contains many options for managing frame numbers and 
checking for frame gaps.

The following tasks are available:
• Find and Replace – Searches for a specific word and replaces it with another. This 

only takes place on the filename, not the frame number. To search on the file extension 
as well, tick Include file extension.
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• Offset Frame Numbers – Increments or decrements the frame number by the 
specified amount. 

• Close Number Gaps – Renumbers frames so that there are no gaps.
• Pad Frame Numbers – Pads frame numbers to the desired length by adding zeroes to 

the beginning.
• Reverse Frame Numbers – Reverses frame numbers. This will cause an image 

sequence to play backwards.
• Reorder Frames – Renumbers frames according to their order in the file pane. Drag 

files in the pane to change their order.
• Remove Frame Number – Removes the frame number.
• Change File Extension – Changes or adds a file extension.
• Remove File Extension – Removes file extensions. Note that some files may not be 

openable without an extension.
• Add Prefix – Prefixes the filename with the specified text.
• Add Suffix – Adds the specified text after the filename but before the file extension. If 

you want to add the text before the frame number, tick Add before frame number.
• Insert Characters at Position - Inserts text at the specified position. A position value 

of 0 inserts it before the first character.
• Replace Range with Characters - Replaces characters between the start and end 

positions with the specified text.
• Remove Characters From Start – Removes the specified number of characters from 

the start of the filename. If the number of characters equals or exceeds the length of 
the filename, no changes will occur.

• Remove Characters From End – Removes the specified number of characters from 
the end of the filename before the frame number and file extension. If the number of 
characters equals or exceeds the length of the filename, no changes will occur.

• Remove Characters In Range – Removes the specified number of characters from 
within a filename. If the range equals or exceeds the length of the filename, no 
changes will occur.

• Convert Spaces to Underscores – Replaces spaces in filenames with underscores – 
e.g. My File.jpg becomes My_File.jpg.
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• Strip Non-Alphanumeric Characters – Strips all characters that are not letters, 
numbers or basic punctuation.

• Remove Trailing Spaces – Removes spaces at the end of a filename –  
e.g. MyFile .jpg becomes MyFile.jpg.

• Make Uppercase -  Makes all characters in the filename except the file extension 
uppercase.

• Make Lowercase -  Makes all characters in the filename except the file extension 
lowercase.

• Lowercase File Extension -  Converts the file extension to lowercase.
• Uppercase File Extension -  Converts the file extension to uppercase.
• Capitalize Each Word – Capitalizes the first letter of every word in the filename – e.g. 

my file.jpg becomes My File.jpg.

Quick Start
1. Drag files into the window.
2. Choose a task.
3. Examine the Preview column to see what the new filenames will be.
4. Click Rename. The application will ask you to confirm that you wish to proceed.
5. Once renaming is complete the new filenames will be added to the file list, allowing you 

to perform additional actions on them.

 
Filename Conflicts
The new filename for a file may conflict with a file that already exists in the folder. Batch 
Renamer has several options in the Preferences window for dealing with this:

• Move existing file to separate folder – This creates a new folder called Conflicting 
Files and moves the old file to this folder. This is the default option.

• Rename existing file – This appends some random text to the end of the old file to 
ensure it is unique.

• Send existing file to Trash – This trashes the existing file.
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• Skip File – Does not rename the file.

Frequently Asked Questions
Q: How can I locate frame gaps without actually closing them?
A: Go to Tools > Check for Frame Gaps.
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Edit Detector

Scans video files to produce a list of edit points within the file. It does not 
check for timecode breaks but scans the actual frames, so it can be used 
with edited movies or files without timecode tracks.
Once Edit Detector has scanned the frames the results will appear in the 
list below. The default settings will work for most movies but there may be 

anomalous results if the movie contains long pans or slow cross dissolves. In these situations 
you can adjust the Sensitivity slider at the bottom to compensate – less sensitive for long 
pans, more sensitive for slow cross dissolves. You can also modify and delete edit points.
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Quick Start
1. Launch Edit Detector and open a QuickTime movie.
2. Wait for it to build information about the frames.
3. If there are some anomalous results, adjust the Sensitivity slider and click 

Recalculate.
4. Export the results as separate QuickTime movies (self-contained or reference), 

markers within a Final Cut Pro XML file, Final Cut Pro marker lists, Avid locator files, 
EDLs, ALEs, CSV or text. 

Frequently Asked Questions
Q: Why doesn't Edit Detector spot very quick shots of 1-2 frames?
A: Edit Detector expects all shots to be at least 5 frames in length. This reduces the chance of 
anomalies. 
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Post Haste

Post Haste is an essential project management tool that makes it easy to 
create customized folder structures for each project.

For more details about Post Haste, please see the user manual located 
within the Help menu of Post Haste.
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Project Overview

Provides a complete overview of your Final Cut Pro project or XML file, 
showing all media, effects and markers within the project. Data can be 
printed and edited en-masse.

Media
This pane shows a complete list of all media files within the project and how many times they 
have been used within a sequence.

The pie chart shows the disk space taken up by the media as a percentage of the total space 
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available.

Effects
This pane lists all of the effects within the project. The checkboxes on the left can be used to 
enable and disable the effect.

Show Default Filters displays the filters that are added to every media file in a Final Cut Pro 
project by default, such as Crop, Distort, Motion Blur, Opacity. These filters are hidden by 
default.
The search box allows you to filter effects by name. You could use this to show only color 
correction filters for example.
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Markers  
This shows a list of all markers within the project.

Offset moves the selected markers left or right on the timeline by the specified number of 
frames.
Custom Fields allows you to setup new columns within the markers table to contain 
additional data. These fields can then be printed. This extra data column could be used to 
indicate in a printout, for instance, that a specific marker refers to a visual effects shot.
Label Presets allow you to assign names to colors, so you could name red “Needs fixing” 
and green “Fixed” for instance. This would allow other people to know what the colors refer to.
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Frequently Asked Questions
Q: Why is the usage count listed as zero?
A: Project Overview only calculates this for clips in your browser. It cannot see media files that 
only exist in a sequence or were added to a sequence before being dragged into the browser.
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QT Edit
QT Edit allows you to add and remove tracks from QuickTime movies, edit 
chapters, modify metadata and more. All changes will be displayed in the 
real-time preview window.
The main window shows a list of all of the tracks in the file. Selecting a 
track populates the tab bar at the bottom with options specific to that 
particular type of track.

Info
This shows statistics about the movie file including frame rate, codec and track structure.

Quick Tasks
This tab allows you to perform common tasks quickly such as removing empty tracks, 
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removing all audio tracks except track 1 and creating timecode tracks automatically from 
metadata.

Conform
QT Edit can convert a movie from one frame rate to another. It can also conform a movie shot 
at a high frame rate to slow motion.
By default the Conform pane shows the current frame rate in the dropdown menu. Select a 
different frame rate and then click Conform.
Important: This operation is destructive and cannot be undone so it is best performed on a 
duplicate of the file. Conforming will also immediately write all unsaved changes to disk before 
the conform occurs.

Chapters
This tab shows all of the chapters within the file. Chapters can be added, removed or 
modified. To import chapters from another movie, a Final Cut Pro marker list or an Avid locator 
file, go to File > Import > Chapters. Remember to select the appropriate file format from the 
File Type dropdown menu before importing.
Chapters can also be exported to various formats including Final Cut Pro marker lists and 
Avid locator files. To do this, go to File > Export > Chapters and select the appropriate 
format from the File Type dropdown. 

Metadata
This tab displays additional data about the file that other applications can read, such as the 
copyright information, the type of camera it was created with or the identification number of 
the file within Final Cut Pro.
Metadata can be added by clicking the + button. You can add application-specific metadata 
from the presets available in the popup menu or you can select Custom to specify your own.
In the custom metadata window that appears you must enter an attribute key and value. The 
key must be in reverse DNS format (for example, if your website is site.example.com it would 
be com.example.site) like com.mycompany.myproduct.keyname. As an example, the key 
name Final Cut Pro uses to identify a reel name is com.apple.proapps.reel.
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Metadata can be imported and exported to CSV and text formats via the File menu. 

Encoding Attributes
This tab shows various settings for displaying the file such as the pixel aspect ratio and field 
dominance. These allow you to correct information about how the file was encoded if it is 
stripped out by another application. These settings should be adjusted with caution.

Batch Processing
QT Edit can perform actions on multiple files at once. Go to File > New Batch to open a 
batch window. After adding the files you wish to process, use the tabs at the bottom of the 
window to adjust settings as desired (see above for descriptions of each tab).

As you change options, they will appear in the Queued Tasks list at the right. This lists all of 
the tasks that will be performed on the file when the batch is processed, in the order in which 
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they will be performed. So for example, if you have “Disable all audio tracks” followed by 
“Enable all audio tracks”, the resulting movies will have their audio tracks enabled because 
“Enable all audio tracks” was the last task to be performed.
If you make a mistake and wish to remove a task, select it in the Queued Tasks list and press 
the Backspace or Delete key.   
Once you have finished changing settings, click the Submit Batch button. It is important that 
you process the batch otherwise your changes will not be saved to disk.
You have three options for processing the batch. You can update the existing files on disk 
(this is the fastest option), create duplicates of the files with additional text appended to the 
filename, or create duplicates inside a new folder. 
Rewrite entire file automatically rewrites the entire file instead of simply updating it and is the 
equivalent of doing a Save As in single file mode.

Note: if files already exist with the chosen filename they will be overwritten.

Frequently Asked Questions
Q: Why does it say “File is Busy” when I try to save?
This means that another application is using the file. This problem is commonly caused by 
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applications like Final Cut Pro that do not properly surrender their ownership of the file after 
they have finished using it. The solution is to close the offending application or project, save 
under a different name or delete the file and re-save it.
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Quick Bins
Quick Bins is designed to quickly generate bins in order to assist with 
media management. 
There are four types of bins available:
Empty Bin – This is an ordinary bin that you can place special bins 
inside.
Bin Range – This generates a group of bins numbered in sequence. This 

can be useful for quickly creating bins for every scene in a movie for example.
Smart Bin – This automatically moves media files matching a specified criteria into the bin. 
You could use this to automatically add all DV clips marked “Good” for instance.
Smart Bin Range – Automatically creates a new smart bin for each variation of the criteria. 
For example, you could use File Extension as the range criteria and it would create an “mov” 
bin for all movie clips and an “aiff” bin for the audio and automatically move video and audio 
files to these bins.

Quick Start
1. Load Quick Bins and open a Final Cut Pro project or XML file.
2. Click the Empty Bin, Bin Range, Smart Bin or Smart Bin Range buttons to add bins.
3. Once you have finished configuring your bins, go to File > Send to Final Cut Pro (for 

Final Cut Pro projects) or File > Save (for XML files).

Frequently Asked Questions
Q: Why doesn't all of my media appear when I add a Smart Bin or Smart Bin Range?
A: Quick Bins only processes clips in your browser. It cannot see media files that only exist in 
a sequence.
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Render Watcher

Render Watcher watches Compressor batches, render files and custom 
directories and notifies when a render is complete. 
When a render is complete it can:
• Play a sound

• Display a Growl notification
• Show the completed file in Finder
• Open the completed file in QuickTime Player
• Send an email
• Send a text message
• Send the completed file to an application such as Compressor
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Quick Start
1. Launch Render Watcher.
2. Tick the boxes next to the applications you wish to watch for renders. Note that ticking 

these boxes only covers renders within the applications and not exports to external 
files (such as File > Export > QuickTime Movie in Final Cut Pro). If you need to watch 
exports too, add your export destination as a watch folder.

3. If necessary, add additional watch folders.
4. If you wish to use Growl notifications, you must install Growl from http://www.growl.info.
5. Perform a render in one of the selected applications.

Please note that it may take up to 15 seconds for the notification to appear after a render has 
finished.

Frequently Asked Questions
Q: How do I get Render Watcher notifications on my iPhone / iPad?
A: Download and install Growl (www.growl.info) onto your computer and make sure the 
checkbox for Growl notifications in the Actions pane of Render Watcher is switched on. Then 
install a notification app such as Boxcar (www.boxcar.io) or Prowl (www.prowlapp.com) onto 
your iOS device. Alternatively, notifications can be sent by email or text message.
 
Q: Does sending text messages cost money?
A: There is no charge for sending text messages but the recipient may be charged for 
receiving them. Please check with the recipient's network provider for further details.
 
Q: If I enter my email address and password, how is this information safeguarded?
A: Email login information is not uploaded to our servers and stays on your system in an 
encrypted form so that others cannot read it.

http://www.growl.info
http://www.growl.info/
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Timeline Tricks
Timeline Tricks performs common tasks on Final Cut Pro sequences 
including:
•Removing disabled clips
•Collapsing video tracks
•Removing unused tracks

• Stripping filters and markers

Only markers and filters can be stripped from Final Cut Pro X projects.
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Quick Start
1. Launch Timeline Tricks and load a Final Cut Pro project or XML file.
2. A window will appear with a list of sequences. Select all of the sequences you wish to 

process.
3. Select the tasks you wish to perform and click Perform Tasks.
4. If you loaded a Final Cut Pro project, the new sequences will be automatically 

imported. If you loaded an XML file, you will be prompted to save it.
5. The processed sequences will be placed inside a Timeline Tricks bin. The original 

sequences will not be modified.

Collapsing Tracks

The primary function of Timeline Tricks is collapsing tracks. This can turn a messy and 
disorganized timeline into a neat and tidy one by moving clips to the lowest possible video 
track allowable without conflicting with other clips.
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If you have lots of clips redundantly layered above each other, choosing the Collapse 
uncomposited clips option will take this one step further by working out which clips are 
redundant and removing or shortening them. This will tidy up your timeline even further, as 
illustrated below.

It will not collapse clips that it knows are transparent, such as text objects and certain filters 
and generators. If you have added a plugin with transparency, you can add it to the effect 
blacklist within preferences. Once the name of the filter is added, Timeline Tricks will not 
collapse clips that contain this filter.

Tips

For best results, make sure that the current Easy Setup is set correctly for your project and 
that the clips on the timeline have corresponding master clips in the browser.

For more complex sequences, you may need to run the collapse operation more than once.
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Video Check
Checks video files for illegal luminance values, flash frames, long frames 
and audio peaks. Results can be exported to Final Cut Pro marker lists, 
Avid locator lists, CSV and text files.
Results can be filtered and sorted according to type or error message, 
and they can even be color coded for easy recognition.

Quick Start
1. Load Video Check and open a QuickTime movie.
2. Click Analyze.
3. A list of problems will appear along with a corresponding timecode position. Clicking on 

any of these problems will jump to the relevant frame in the movie.
4. Optionally, you can export these to various formats by going to File > Export Results.
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Settings

Bit Depth - This allows you to switch between 8- and 10-bit codecs. 8-bit codecs include DV, 
DVCPRO HD and HDV, and 10-bit codecs include ProRes and XDCAM EX. 10-bit processing 
is only supported on OS X 10.7 Lion and higher but 10-bit codecs can still be scanned in 8-bit 
mode.

Check for excess luma - This checks the value of the luma component (similar to 
brightness) of each pixel and alerts you if it is out of the range specified by the Maximum 
black and Minimum white text boxes.

Unlike video destined for a computer monitor, broadcast video does not fill the entire 0-255 
pixel value range of an 8-bit codec because some values are used to store extra data 
unrelated to the visual image. The safe range (Studio swing) for 8-bit codecs as specified by 
the Rec. 601 and Rec. 709 broadcast standards is 16-235. Sending video to broadcast that is 
out of the safe range can theoretically have adverse affects such as visual artifacts or audio 
cutouts, although most broadcasters now have limiters that automatically clip out-of-range 
pixels. Clipping can degrade the image and broadcasters expect submitted programs to be 
within the legal range.

Video Check is very strict and will alert you to minor errors that are probably too small to 
notice on your software scopes. Each error will be followed by two numbers - the first is the 
luma value of the lowest or highest pixel in the frame and the second is the percentage of 
pixels in the entire frame that are outside the limits. 

Video Check is designed to inform and it is up to the user to decide what to do based on the 
results. If the deviation from the legal range is small, the out-of-range values make up less 
than 1% of the pixels and you cannot spot it by eye in your NLE’s scopes, you may decide 
that this is an acceptable margin of error.

Check for flash frames - This checks for short frame flashes that can appear in your video if 
a gap is inadvertently left in your timeline or a few frames of a clip are accidentally cut in.

Flash frame length - This allows you to specify how long of a gap will be considered a flash 
frame. You can adjust this to catch flashes longer than the default of up to 4 frames.
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Flash frame sensitivity - If Video Check is not catching every flash frame in your clip, try 
raising the sensitivity. The scale is exponential so raising it by a notch or two should be 
sufficient in most cases. Raising it too high may result in too many false positives.

Check for dropped frames (long frames) - Each frame in the video should play for the 
same amount of time, however some frames may play for longer than a single frame, which is 
usually an indication that frames were dropped when capturing from a tape.

Enforce aspect ratio mattes - If your video is supposed to have a matte on it, Video Check 
can determine if the matte is the right size and flag up frames where it is too small, too large 
or non-existent. The dropdown menu allows you to select the desired aspect ratio of the matte 
and Video Check will determine what the correct matte size should be based on the resolution 
of your video.

Check for audio peaks - Audio that is too loud will be clipped upon playback, which distorts 
the sound and is undesirable. This checks for peaking audio.

Check for timecode track - Checks for the presence of a timecode track and alerts you if 
one doesn’t exist. 

Start timecode must be - If your company has a specific policy that requires content to begin 
at a certain timecode, Video Check can be used to flag up movies that don’t match.
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Software Updates
By default, all applications are set to check for updates at startup. This can be disabled by 
launching Digital Rebellion Software Update (in /Applications/Digital Rebellion) and disabling 
Check for updates whenever a Digital Rebellion application is opened in the Preferences 
dialog.

 
Support
Email support can be accessed directly within each application.

! To report a bug or any other issue, go to Help > Report a Bug.
! To request a new feature, go to Help > Suggest a Feature.

When emailing customer support, it is helpful to include log files from the relevant application, 
if available. To access the logs, go to Help > Troubleshooting  > View Log or Help > 
Troubleshooting > Gather Logs to place all log files on your desktop.
Before emailing support, please visit our support site at http://www.digitalrebellion.com/
support/promedia to see if your question has already been answered.

http://www.digitalrebellion.com/support/promedia
http://www.digitalrebellion.com/support/promedia

	Pro Media Tools
	User Manual
	Auto Transfer
	Batch Renamer
	Edit Detector
	Post Haste
	Project Overview
	QT Edit
	Quick Bins
	Render Watcher
	Timeline Tricks
	Video Check
	Software Updates


