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Preference Manager 2.0.4

User Manual

Preference Manager gives you everything you need to manage your Final Cut Studio
preference files. Preference files contain user settings, window positions and other
information. Sometimes these can become corrupt, preventing Final Cut Pro from launching
or producing unexpected behavior. Preference Manager allows you to trash these which will
restore restore settings to their defaults when the application is relaunched.

Even more useful is the ability to backup and restore preferences, or lock them to prevent
unintended modification. You are not limited to just preferences either — Preference Manager
allows you to backup and restore keyboard layouts, button bars, window layouts and more,
storing them in a single file to ease transition between computers. Now it is incredibly easy to
take your custom preferences wherever you go.

Version 2.0.x is a complete redesign that allows you to assign categories to organize your
backups and automatically assign preferences on a per-project basis.

What's new in this version (2.0.4)

e Feature: Final Cut Express support.
e Improvement: Snow Leopard compatibility.
e Improvement: Improved compatibility with FCS Maintenance Pack.
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Quick Start

Trashing All Preferences

1. Launch Preference Manager.
2. Click Quick Trash.

Note: this only trashes preferences, not button bars or other files.
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Trashing Selected Preferences Only
1. Launch Preference Manager.
2. Click the Advanced tab.

| Basic | Advanced }
(3 ™ Final Cut Pro a ;
= ﬁ M Soundtrack Pro =
[ 2 % ™ Motion [*]
= ‘ ™ Color =
> @ ™ DVD Studio Pro a
= ﬂ gLiueType =
(3 @ W Compressor a
B m ™ Batch Monitor =
2 W P o LY
b

3. Select the applications for which you would like to trash preferences.

Note: some applications, like Final Cut Pro and Compressor, have additional options
such as button bars and custom settings that will also be deleted if you do not deselect
them.

4. Click Trash.
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Backing up All Preferences

When you first launch Preference Manager, it will automatically create a backup of your
current preferences under the current username. If you want to create a new backup, follow
the steps below.

1. Click Backup.
2. Inthe dialog that appears, select the type of backup.

Type: [ 2= Project 3

Name:  Untitled Project

Project: i| I[ Browse... J

[ Create Backup J

User — a backup of a particular user's favored settings
Project — custom settings for a particular project
Workflow — custom settings for a particular workflow

3. If you selected Project, an additional text box will appear allowing you to select a
project to link the backup to. This is optional and will automatically load the current
backup whenever the project is launched from disk (note: this does not function if you
open the project within Final Cut Pro).

4. Click Backup to create the backup or press Escape to cancel.
If you selected Project as the backup type, you may receive the following prompt:

For correct operation of project-linked backups, click Yes. For more details, see the Project
Handling section of this manual.

Handler not set

In order to use project-linked backups, you must set
Final Cut Studio projects to open with Preference
Manager by default. Would you like to do this now?

e ) @
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Important: if you previously trashed your preferences, you will need to relaunch your Final
Cut Studio applications in order to generate new preference files, otherwise there will be
nothing to backup.

Project backup icons

If you choose Project as the backup type and then link the backup to a project file, a linked
chain icon will appear underneath the backup icon to indicate it is linked to a project. Hovering
the mouse over the icon will reveal the name of the project it is linked to. If the project cannot
be found, a broken chain icon will appear.

.lr}.-, ’Lf lﬂ-i
Unlinked project backup Linked project backup Invalid project backup

Backing up Selected Preferences
1. Click the Advanced tab.
2. Select the files you would like to backup.

3. Click Backup and follow the steps above in the Backing up All Preferences section
from step 2 onwards.

Restoring Preferences
1. You will first need to have backed up your preferences using the steps above.

2. In the Basic tab, double-click the backup you would like to restore, or ctrl-click it and
select Restore from the menu.
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Locking Preferences
Locking your preferences is a good way to prevent corruption or modification by the user.

1. Click the Advanced tab.
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2. Either click the right-hand column next to each item to lock it, or select a group of items
and click the Lock button.

3. If the lock icon does not appear next to an item, this means that Preference Manager
could not find a file to lock. If you previously trashed preferences, you must relaunch
the application(s) in question to generate new preference files.

Note: If you trash your preferences, you will need to lock the regenerated files again.
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Editing Backups

You can edit backup settings by going to Edit > Edit Selected Backup or by ctrl-clicking on a
backup and selecting Edit. The dialog that pops up is identical in appearance and
functionality to the Create Backup dialog.
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However, not all editing actions need to be performed in this dialog. You can rename a
backup simply by clicking on the name again after it has been selected, just like most OS X
applications.

You can also quickly remove a project link by ctrl-clicking a backup and selecting Project >
Remove Link.
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Common Usage Scenarios
Transferring settings from one machine to another

1. Backup your preferences using the steps outlined in Backing up All Preferences or
Backing up Selected Preferences.

2. Ctrl-click on the backup and select Show in Finder.
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3. AFinder window will appear with the file selected.

-
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4. Transfer this file to the other computer. Possible methods include emailing the file,

sending it via FTP, transferring it across a network, putting it on a CD or placing it on a
USB thumb drive.

5. Install Preference Manager on the destination computer and double-click the .pmb2 file
to open it in Preference Manager.

o Are you sure you wish to restore this
backup?

(Yes)fﬂu'a
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6. Click Yes to restore the backup.

Assigning FCP scratch disk settings to a particular project
1. Click the Advanced tab and uncheck Select All to deselect all the items in the list.
2. Click the disclosure triangle next to Final Cut Pro and select Preferences.
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3. Click Backup.
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4. Select Project, type a relevant name in the Name field and click the Browse button to
select the project in question.

Type: | 2 Project 3

Mame:  Untitled Project

Project: | Users/Jon/Desktop/Untitled Project 1.fcp L Browse... J

|_Create Backup_|

5. Click Backup. If a prompt appears asking you to assign Preference Manager as the
project handler for all Final Cut Studio projects, click Yes. For more details about this,
see Project Handling.

Handler not set

In order to use project-linked backups, you must set
Final Cut Studio projects to open with Preference
Manager by default. Would you like to do this now?

(N ) @
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6. Double-click on the project file to open it. This will restore the backup and then launch
Final Cut Pro automatically. This will not work if you drag the project into Final Cut or
open it using the File > Open command.

P>

Untitled Project 1
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7. To launch a different project, double-click the project file. Preference Manager will
attempt to close Final Cut Pro, restore the backup and relaunch it again with the new
project.

Preventing users from changing settings
1. Click on the Advanced tab.
2. With all of the items selected, click the Lock button.

3. Remove Preference Manager from the hard drive or use OS X's Parental Controls to
limit access to it to prevent users unlocking these items.

Troubleshooting Final Cut Studio issues
1. Click Quick Trash to remove all prior preferences.

2. Open the relevant Final Cut Studio applications and set the user preferences to your
liking.

3. Click Backup to create a new backup.

4. When your Final Cut Studio applications experience problems, just restore the backup
instead of trashing preferences.

Importing old backups

If you have .pmb backups from an older version of Preference Manager, you will need to
convert them to .pmb2 files in order to use them with the latest version.

When Preference Manager starts up, it checks for .pmb files in your backup directory and
automatically converts them to the newer format. However, if you wish to manually import
(and restore) a .pmb backup, go to File > Open Backup.

Go to File > Import Backup if you wish to import and convert the backup without
automatically restoring it.
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Preference Manager Settings

General

Backup Location: | [Users/Jon/Library/Application Suppo| Lﬁﬁ&r&] [_ﬁjjf}_n]

Here you can change the location where backups are stored. Change this if you would like to
store backups on an external drive or would like them available to all users (by default users

can only see backups they created).

Click Reset to restore the default backup location.
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Project Handling

[ NN Preferences =)

Use this to set Preference Manager as the default handler for all Final Cut Studio
projects. This will cause all projects to open with Preference Manager before
launching the relevant application. This is crucial to the operation of project-
linked backups.

Status: Preference Manager is the default handler

| Assign to Preference Manager | | Restore to Original FCS Apps |

In order for project-linked backups to work, Preference Manager must be set as the default
handler for all Final Cut Studio projects (Final Cut Pro projects, Motion projects, Soundtrack
Pro Multitrack projects, etc). This will cause these projects to open with Preference Manager
instead of the relevant Final Cut Studio application. Preference Manager then launches in the
background, restores the backup, launches the relevant application and quits. This is invisible
to users and does not introduce a noticeable delay.

This functionality has many useful purposes, however it is acknowledged that users may not
want this functionality switched on without their knowledge or permission so it is switched off
by default.

You can switch this on either by creating a project-linked backup and clicking Yes when
Preference Manager asks if you would like to enable this functionality, or by clicking the
Assign to Preference Manager button in the Project Handling tab of the Preferences dialog.

It is very easy in this dialog to see the current status and switch it between Preference
Manager and the default Final Cut Studio applications.
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Use this to set Preference Manager as the default handler for all Final Cut Studio
projects. This will cause all projects to open with Preference Manager before
launching the relevant application. This is crucial to the operation of project-
linked backups.

Status: Preference Manager is NOT the default handler

Assigu E:}. Preference Manager

Remember to switch this off if you decide to uninstall Preference Manager. If you forget to do
this before uninstalling, you can just ctrl-click on a Final Cut Studio project and select Get
Info. In the dialog that appears, select the relevant Final Cut Studio application in the Open
With section and click Change AlI.

¥ Open with:
| & Final Cut Pro -
Use this application to open all documents
like this.

Change All...
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Updates

[ N ] Preferences =

E Check for updates at startup

This allows you to check for updates at startup. If you switch this off, you can still check for
updates by going to Preference Manager > Check for Updates.

Alternatively you can subscribe to our appcast feed here:
http://www.digitalrebellion.com/appcast.xml

Keyboard Shortcuts

Trash -8 + T
Backup - 3 + B
Restore — Enter

Open Backup - 3 + O
Import Backup - 3 + |
Edit Backup- 3 + ¢ + E
Remove Backup — Delete


http://www.digitalrebellion.com/appcast.xml
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Support

Email support can be accessed directly within Preference Manager.
e To report a bug or any other issue, go to Help > Report a Bug.
e To request a new feature, go to Help > Suggest a Feature.



